Mac OS X

Create Disk Images of Floppy, CD, DVD, or Disk Storage To Recover Data On A Mac

We’re going to make a disk image of a floppy in this article. Before we start it’s best to use what we call a write blocker. These are devices that can block the ability to write to a volume. This prevents accidentally erasing potentially sensitive information. The Wiebetech https://wiebetech.com/products/usb-3-1-writeblocker/ works with the Mac but ymmv. There are also software tools like Mac Forensics Lab, but many require someone be in law enforcement to buy all or part of. There are also a few tools out on the old GitHub that can be used to kill and track the disk arbitration daemon that attempts to mount volumes.

Next, run diskutil with the list verb to see a list of the devices in /dev:

diskutil list

Now insert the drive and run the command again. There should be a

sudo dd if=/dev/disk6 of=nameofdiskimage.dd bs=512

To make that an iso:

sudo dd if=/dev/disk6 of=nameofdiskimage.iso bs=512

The Mac will, upon first use, prompt to give access to the disk drive.

Either all the data will be transferred (e.g. for a floppy that would be around 1474848 bytes) or probably none. If none, there might be a single error on the disk so let’s skip errors and just pull everything:

sudo dd if=/dev/disk6 of=nameofdiskimage.iso bs=512  conv=noerror,sync

Let’s stat the iso to make sure there’s data and it’s a complete file:

stat nameofdiskimage.iso

Next, let’s see if the operating system knows the filesystem:

hdiutil imageinfo herman.iso 

If the partition-scheme and partition-hint are filled out then there’s a good chance the file system will mount. If not, it’s highly unlikely. Provided it’s a known filesystem type (e.g. HFS, HFS+, etc), let’s try to mount the iso:

hdiutil mount nameofdiskimage.iso 

If the image mounts, the journey is over. If it doesn’t then there are a few other things we can try. Apple removed support for HFS in Catalina so an option would be to try a system that runs an OS before that. Another is to use an emulator. DOSBox is a tool that can be downloaded at https://www.dosbox.com and runs an Apple DOS emulator. So we’re talking pre-Mac era file systems. That can be used to mount an image and might be able to mount the image. Keep in mind there was a character limit on file sizes “back in the day” so it’ll be truncated. So nameof~1.iso would be the name that appears in DOSBox, rather than nameofdiskimage. Further, volumes were mounted to drive letter paths in DOS; ergo we’ll specify a letter like D in the following example

imgmount d "Z:/nameof~1.iso" -t iso

If the disk image is a classic Mac operating system, there’s less command line foo required but a bit more downloading and button mashing. Basilisk ( https://basilisk.cebix.net/#download ) and Mini vMac ( https://www.gryphel.com/c/minivmac/start.html ) are two options for emulating classic Mac environments to mount an iso (or the actual disk). One is supposed to have a Mac to run those to be legit, so another option would be to try and drop a disk into that actual Mac. A Performa, LC, or early early PowerBook (e.g. 100 or 200) are great machines, and should be backwards compatible to be able to read the older Mac disks and slightly newer ones – so not a bad option.